Установка приложений в DEEPEN

Всем привет,  был недолгим пользователем Mint 18, сейчас перешел на deeepen, немного  не догоняю , вот например:

Есть приложение которого нету в магазине (https://github.com/buglloc/brick/) , я как по привычке беру и через терминал начинаю ставить:

то есть  добавляем репозиторий командой

sudo add-apt-repository ppa:buglloc/brick

Но он мне sudo: add-apt-repository: command not found

Так вот в чем вопрос,  как мне устанавливать приложения не из магазина? 
На что обращать внимание при скачивании?  Брать приложения совместимые с убунту?  или искать на Debian ?

Изначально дипин не умеет добавлять репы через add-apt…

Нужно установить software-properties-common

sudo apt-get install software-properties-common

5 дней назад.
Ответить

Synaptic установите, либо deb пакетом через установщик.

Новичок Отвечено 11.06.2018.

Deepin 15.5 версии основан на Debian 8 ( а не на Ubuntu как раньше). Так вот, в Debian нельзя по умолчанию добавить PPA репозитории (это вам не ubuntu). Можно искать репозитории для Debian 8 или как написали выше.

оказалось все даже проще, поставил из  исходников

Or you can build Brick from sources:

# Install build tools
sudo apt-get install build-essential cmake
# Install dependencies
sudo apt-get install libgtk2.0-dev libudev1 libnss3 libgconf-2-4 libnotify-dev libxss-dev
# Install tools to register Brick desktop entries, icons, etc in system
# Or you may skip this installation step by adding -DSKIP_BRICK_REGISTER=1 to cmake
sudo apt-get install desktop-file-utils xdg-utils

# Let's make it
mkdir ~/tmp && cd ~/tmp
git clone --recursive https://github.com/buglloc/brick.git
mkdir build && cd build
cmake ../brick
make
sudo make install

# And run it!
brick

Все работает ,  спасибо за помощь

Ваш ответ