Не могу обновить драйвера AMD

Скачал драйвера с оф.сайта и при попытке обновить выскакивает ошибка:

 

AMD Catalyst(TM) Proprietary Driver Installer/Packager ===================================================================== error: Detected X Server version ‘XServer 1.19.3_64a’ is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.19.3_64a:none:4.14.0-deepin2-amd64:) Installation will not proceed. ===================================================================== AMD Catalyst(TM) Proprietary Driver Installer/Packager ===================================================================== error: Detected X Server version ‘XServer 1.19.3_64a’ is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.19.3_64a:none:4.14.0-deepin2-amd64:) Installation will not proceed.

 

Прошуршав гугл, ответа так и не нашел. Пробовал «убить иксы» и поставить так, но тоже не помогло.

P.s. Так же попробовал обновить через Deepin Graphics Driver Manager, но успехов не принесло.

Называние видеокарты и ссылку на официальный сайт с этим драйвером.

amd mobility radeon hd 5470

 

https://support.amd.com/ru-ru/download/desktop/previous/detail?os=Linux+x86_64&rev=15.9

Этот драйвер не подойдет.

Версия иксов выше чем поддерживает драйвер
у вас : XServer 1.19.1_64a
Максимальная версия у драйвера XServer 1.10

(Это как на ш10, ставить драйвер от ш98)

Deepin Graphics Driver Manager не предлагает ни какие варианты?

Ваш ответ