[РЕШЕНО] Как отключить Unicode и Emoji в Deepin 15.7?

Отвечено

Всем привет! При нажатии Сtrl+Shift+E открывается ввод emoji, при нажатии Ctrl+Shift+U открывается ввод unicode. Проблема: не могу использовать эти сочетания в других приложениях, когда в фокусе ввод текста Например, в Visual Studio Code Ctrl+Shift+E должно открывать File Explorer, но вместо этого, если в фокусе какое-нибудь текст поле, открывается ввод emoji. Вопрос: как отключить?

[РЕШЕНО] Как отключить Unicode и Emoji в Deepin 15.7?

Лучший ответ

Решил проблему сам. Нужно в ~/.bashrc добавить в конец файла:

export GTK_IM_MODULE=xim
export XMODIFIERS=@im=xim
export QT_IM_MODULE=xim

Потом добавить в настройки в gtk (навсякий случай добавил в два файла):
в ~/.gtkrc-2.0

gtk-im-module="xim"

в ~/.config/gtk-3.0/settings.ini

gtk-im-module=xim

Уже был данный вопрос. Стандартно таких комбинаций клавиш нет. Проверьте установленные приложения или зайдите в настройки комбинаций клавиш

Переустановил Deepin. Ничего стороннего не устанавливал, но проблема осталась. Дело не в приложениях

03.11.2018.
Ответить

Ваш ответ